How to configure feed_backward in PID

X-Series and R-Series Actuators
Post Reply
husch
Posts: 16
Joined: Fri Oct 30, 2020 6:18 am

How to configure feed_backward in PID

Post by husch » Fri Oct 30, 2020 6:26 am

In the iROS HEBI tutorial of motion control, it is mentioned that when using strategy 4, we can disable effort feedback in effort PID, as shown in the graph attached.
But how do we disable it? There is no configuration for feed_backward in gain configuration, either in xml format or in Scope tool.
Thanks a lot :-)
BTW, the tutorial in iROS is very helpful.

<group_gains>
<control_strategy>4</control_strategy>
<effort>
<kp>0.25</kp>
<ki>0</ki>
<kd>0.001</kd>
<feed_forward>1</feed_forward>
<dead_zone>0</dead_zone>
<i_clamp>0.25</i_clamp>
<punch>-0</punch>
<min_target>-10</min_target>
<max_target>10</max_target>
<target_lowpass>1</target_lowpass>
<min_output>-1</min_output>
<max_output>1</max_output>
<output_lowpass>0.9</output_lowpass>
<d_on_error>0</d_on_error>
</effort>
</group_gains>
Attachments
Screenshot from 2020-10-29 17-36-05.png
Screenshot from 2020-10-29 17-36-05.png (66.74 KiB) Viewed 7327 times
User avatar
florian_enner
HEBI Official
Posts: 30
Joined: Wed Mar 25, 2020 11:31 am
Location: Austria

Re: How to configure feed_backward in PID

Post by florian_enner » Fri Oct 30, 2020 8:52 am

You can "disable" the effort feedback portion by only using the FeedForward term (=1) and setting Kp,Kd,Ki to zero. This way the torque controller serves as a unit conversion from actuator specific units to Nm/rad.
husch
Posts: 16
Joined: Fri Oct 30, 2020 6:18 am

Re: How to configure feed_backward in PID

Post by husch » Fri Oct 30, 2020 10:47 am

Yes, of course!! It makes sense.
Thanks a lot :-)
Post Reply